WordPress.org

GlotPress

Opened 4 years ago

Last modified 8 weeks ago

#39 reopened enhancement

Related strings

Reported by: MartinIQ Owned by: somebody
Milestone: Future Release Priority: normal
Version: Component: general
Keywords: related strings see also Cc: sushkov

Description

It would be really cool if we could have some kind of 'related strings' feature, when opening the details of a particular string.

Let's say I'm working on the wordpress.com translation and open/double click a string for translation e.g. 'draft'. It would help a lot to see a list of all other strings of that particular language which contain the word 'draft' in order to see how 'draft' has been translated in other places to keep the whole translation consistent.

Change History (11)

comment:1 nbachiyski4 years ago

  • Milestone set to Future Release

comment:2 sushkov18 months ago

  • Cc sushkov added
  • Keywords changed from related strings, see also to related strings see also
  • Resolution set to duplicate
  • Status changed from new to closed

This looks like a duplicate of #9.
Reopen if I'm missing something.

comment:3 follow-up: vanillalounge17 months ago

Reopen if I'm missing something.

#9 mentions past translations, but it seems that there are more cases. The first consideration is past vs. current, where I argue that past translations are perhaps not as useful as current translations, which could be

  • translations of string in version X of project Y
  • translations of string in all versions of project Y
  • translations of string in all versions of all projects (in the current install of GP)

In my mind, clicking on a link in the detail view opens a pop-up that lets me choose what I want to see from the options above, each instance with a "use this for current string" link. Or something.

comment:4 in reply to: ↑ 3 MartinIQ17 months ago

You said in the GlotPress P2 Blog:

... could we continue this conversation there?

Sure. Would have done that, if the ticket had not been closed. ;)

... searching by filename ... you already can do that

I know. Unfortunately you have to know the filename in order to search for it. In case of the WP.com GlotPress that's impossible as it doesn't show the filenames in detail view.

Replying to vanillalounge:

In my mind, clicking on a link in the detail view opens a pop-up that lets me choose what I want to see from the options above, each instance with a "use this for current string" link. Or something.

Wow. That's more than what I came up with. Totally love your idea.

comment:5 follow-up: vanillalounge17 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

In case of the WP.com GlotPress that's impossible as it doesn't show the filenames in detail view.

I suspect that that is the intended behaviour on WordPress.com, you'll need to take it up with them, I reckon.

comment:6 in reply to: ↑ 5 MartinIQ17 months ago

Replying to vanillalounge:

I suspect that that is the intended behaviour on WordPress.com ...

Well, not intended. As far as I remember some staff told me about technical difficulties based on how translations are handled on WordPress.com. So no sense in taking it up with them.

comment:7 follow-up: vanillalounge17 months ago

...technical difficulties based on how translations are handled on WordPress.com

Unless things have drastically changed since I've worked there, the only difficulty that I can imagine is pointing a string to the source code which, as far as I know, is not visible to the outside (unlike .org, which is on Trac). .com gathers all strings (core, plugins, widgets, themes) in a single file .pot file, it's true but to not link a string to its place in the code is not a technical hurdle or a limitation of GlotPress, it's by design of t.w.c's own installation of GlotPress.

comment:8 follow-up: vanillalounge17 months ago

That said, searching by filename does work on t.w.c, you just need to know the name.

comment:9 in reply to: ↑ 8 MartinIQ17 months ago

Replying to vanillalounge:
That's what I was talking about in comment 3. ;)

Unfortunately you have to know the filename in order to search for it.

Last edited 17 months ago by MartinIQ (previous) (diff)

comment:10 in reply to: ↑ 7 MartinIQ17 months ago

Replying to vanillalounge:

Unless things have drastically changed since I've worked there, ...

Oops, I wasn't aware you don't work for Automattic any more.

... but to not link a string to its place in the code is not a technical hurdle or a limitation of GlotPress, it's by design of t.w.c's own installation of GlotPress.

Get it. All I know is, t.w.o shows comments and references in the Meta section while t.w.c doesn't. When asked about it, an automattician (can't remember who) told me it's because of their system at Wordpress.com. Hope they will fix this some day. :)

Note: See TracTickets for help on using tickets.