WordPress.org

GlotPress

Opened 2 years ago

Closed 13 months ago

#193 closed enhancement (worksforme)

Option to automatically approve submitted translations by default

Reported by: sooskriszta Owned by: nacin
Milestone: Priority: blocker
Version: Component: general
Keywords: Cc: pavelevap

Description

This ticket follows discussion at http://wppolyglots.wordpress.com/2012/04/22/how-exactly-does-http-translate-wordpress-org-work/

The way the system works at the moment is this:

  1. The fields are put up on the web (say at http://translate.wordpress.org/projects/bbpress/plugin/it/default ). These are all marked "untranslated".
  1. Translators contribute their translations. The fields translated are marked "waiting"
  1. Validators go through the fields one-by-one, and approve or remove them. The approved fields are marked "translated".
  1. At various points other translators find that in the context, there are some better options for particular strings. So they go to step 2 above.

In theory, this is a sound system. The problem is that validators are a bottleneck. Nothing against the people who are working as validators. I'm sure they are fantastic people and are doing their best. But from a systems perspective, they are a bottleneck - if a validator is efficient, being a bottleneck is less of an issue, but (s)he is still a bottleneck - simply by virtue of being a "gatekeeper"...nothing goes through to "translated" without active, manual intervention by a validator.

This creates a certain set of challenges.

First of all, the validators are inundated, nay swamped, with loads of "waiting" strings. They are able to deal with this workload based on their time commitments, resources and priorities.

Secondly, in many cases there is a frustrating and demotivating wait for the translators, who have put in the hard work and submitted loads of translations, and have to wait for (what seems to them) a bureaucrat to sign off.

Thirdly, non-English users and multilingual users have to wait for long durations in order to get access to the software in their desired languages.

e.g. At http://translate.wordpress.org/projects/bbpress/plugin there are plenty of items listed as “Waiting”. e.g. Polish, Romanian, French and Czech have 0% translation completed, but almost 100% strings in “waiting”.

Similarly, at http://translate.wordpress.org/projects/buddypress/dev Danish, Romanian, and Czech have almost 0% translation completed, but almost 100% strings in “waiting”.

One possible solution is this http://wppolyglots.wordpress.com/2012/04/22/how-exactly-does-http-translate-wordpress-org-work/#comment-12883 :

Any translation submitted for "untranslated" strings are automatically approved and moved to "translated". If alternative translations are suggested for "translated" strings, then these alternatives are the ones marked "waiting", and thus are the ones that the validators deal with.

Somewhat like this:

  1. The fields are put up on the web (say at http://translate.wordpress.org/projects/bbpress/plugin/it/default ). These are all marked "untranslated".
  1. Translators contribute their translations. The fields translated are marked "translated", and are available immediately.
  1. At various points other translators find that in the context, there are some better options for particular strings. So they make suggestions. These are marked "waiting".
  1. Validators go through the fields one-by-one, and approve or remove them. The approved fields are marked "translated".

This will have the following effect:

  • The workload on validators would be reduced
  • The translators will be motivated to contribute more, as they can see the fruits of their labor sooner.
  • Non-English-speaking and polyglot users will get the software in their desired language sooner
  • Usage of software among Non-English-speaking and polyglot users will increase

Perhaps, this solution is not for everyone, and perhaps it should be activated on a project-by-project basis. The "low priority" projects such as bbPress and Buddypress that are being waylaid by the current process may choose this option while the "high priority" ones might want to stick on to the current system for a while till the new system proves its chops.

So I would recommend that GlotPress create an option to enable "automatic approval of translations" on a project-by-project basis.

Change History (2)

comment:1 pavelevap2 years ago

  • Cc pavelevap added

And another approach - distribute also waiting strings in specific cases: http://wppolyglots.wordpress.com/2012/04/22/how-exactly-does-http-translate-wordpress-org-work/#comment-12915

comment:2 markoheijnen13 months ago

  • Keywords dev-feedback ux-feedback removed
  • Milestone 1.0 deleted
  • Resolution set to worksforme
  • Status changed from new to closed
  • Version 0.1 deleted

I'm closing this ticket as works for me. The real issue is the way how to become a validator and the speed of that.
Automatically approving a string is wrong to do. You want to be sure of the quality of a translation and two is that it would be a step for people who want to translate that wants that someone is going to look at it.

I created ticket #232 to be able do download files that also includes the strings that are still waiting for approval. This way someone still is able to check the string.

Note: See TracTickets for help on using tickets.